Can't find SDK in '/Library/Developer/CommandLineTools/Platforms'


#1

I’m trying to get started with the ‘Hello World’ project from the RubyMotion website, but I’m encountering the error that I’m attaching in the screenshot. I’m on OSX 10.13.6 and I have XCode 9.4.1 installed. Any help would be appreciated.


#2

Hi John,

Looks like you might be missing some Xcode components (the command line tools, specifically). In the RubyMotion School there is a free preview lecture on the RubyMotion Jumpstart course that walks through the steps to setting up your environment.

If video isn’t your thing, there’s a PDF download with the steps, too. The versions have changed, but these setup steps have not.

Good luck, and check in to the Motioneers Slack if you have any more troubles. There’s usually someone around who can help you out.

~ Lori


#3

Hi Lori,

Thanks for the update, but I do have XCode and the command line tools both installed. It is a bit strange that under ‘components’ in the XCode preferences there was no option to download the command line tools though - I had to download them manually from the developer site. I’ll check out the Slack channel.

John