ERROR! The requested deployment target SDK is not available or supported by RubyMotion at this time


#1

Can’t execute first rake action due to the error on the title. I’m using High Sierra and Xcode version 9.4.1


#2

Hey @Victoriosu!

The latest release of RubyMotion requires Xcode 10 (which went live Monday).


#3

Hey @amirrajan,

I am encountering the same problem with Rubymotion 5.14 on macOS 10.13.6.

I have Xcode 10.0 installed and created an empty project via

motion create --template=osx

When performing rake, I am getting the error message:

ERROR! The requested deployment target SDK is not available or supported by RubyMotion at this time.


#4

Are you using the Starter Edition of RM?


#5

Hey @amirrajan,

thanks for your response. Yes I’m using the Starter Edition.

Best regards


#6

For the starter edition, you’ll need to be on Xcode 10.0 (only the latest version of Xcode is supported). But if you DM on Slack, I’ll help you trouble shoot and hook you up with a indie license for being a “test user” for a better error message. :slightly_smiling_face:


#7

Hey,

Xcode 10.0 is installed, so I’m wondering what could be the problem.

On the RubyMotion feature comparison table, it mentions that development for macOS 10.13 should be supported.

Since I just followed this HelloWorld example, the solution for the problem might be interesting to a lot of people who want to start using RubyMotion.


#8

What’s the output for : ls /Library/RubyMotion/data/ios/ and ls /Library/RubyMotion/data/osx?


#9
ls /Library/RubyMotion/data/ios/
12.0

ls /Library/RubyMotion/data/osx
10.13				librubymotion-repl.dylib

#10

Email me and I’ll get you set up with an Indie license.

Mojave release a few days ago, and Xcode 10.0 is technically supposed to be run on Mojave.

You can use Xcode 9.4 for Mac dev, and Xcode 10.0 for iOS dev… but that’s kind of a pain. Mojave is still new, so I don’t want to force you to update (which is why I’ll hook you up).


#11

Hi,
The same issue on latest macOS Mojave 10.14, Xcode 10.0 and RubyMotion 5.14 starter.
What should I do to resolve it?


#12

Just released a beta. Give this an install and see if it resolves your issue. https://s3.us-east-2.amazonaws.com/amirrajan-public/RubyMotion+5.15.pkg


#13

Wow! It helped! Thank you )


#14

I was getting the same error and so I installed the above linked install file for 5.15. Ended up getting the following error:

/Library/RubyMotion/lib/BridgeSupport2/System/Library/BridgeSupport/ruby-2.3/bridgesupportparser.bundle: [BUG] Segmentation fault at 0x0000000000c96522 ruby 2.3.7p456 (2018-03-28 revision 63024) [universal.x86_64-darwin18]

I reverted back to 5.14 but am still getting the same error. I can provide crash logs if needed.

I’m currently on MacOS 10.14, Xcode 10, RubyMotion 5.14.

Was working on MacOS 10.14, Xcode 9.3.1, RubyMotion 5.12 previously. And MacOS 10.12, Xcode 9.3.1, RubyMotion 5.12 before that.

Thanks


#15

The latest version of RubyMotion 5.16 should have fixed this issue. Be sure to run sudo motion update.