The requested deployment target SDK is not available in RubyMotion at this time


#1

I started seeing this a few weeks ago with Xcode beta, but now that I have upgraded Xcode from the App Store I can’t build apps at all. I use Xcode 9.4 and RubyMotion 5.8. MacOS 10.13.4.


#2

Ah never mind the upgrade fixed it, just in time. RubyMotion rocks!


#3

I’m on it :slight_smile:

Lemme know if you hit any snags!


#4

I was able to fix this for my build by uncommenting the line that specifies the version number in the Rakefile and changing it to the latest version.


#5

Getting the same issue… I downloaded the StarterKit.

  • rake
    ERROR! The requested deployment target SDK is not available or supported by RubyMotion at this time.
  • motion --version
    5.11
  • ls /Applications/Xcode.app/Contents/Developer/Platforms/iPhoneSimulator.platform/Developer/SDKs/
    iPhoneSimulator.sdk iPhoneSimulator11.2.sdk
  • ls /Library/RubyMotion/data/ios/
    11.4

My XCode version is 9.2.