Changing Deployment Target Using motion-game Gem

I’ve built a RubyMotion project using the motion-game template but when I build the project using rake ios:simulator, I get the following message:

ERROR! Deployment target 7.0 is not supported by this version of RubyMotion

I thought I would just be able to specify the deployment target in the config/ios.rb setup file like so:

Motion::Project::App.setup do |app| = 'hello'
   app.deployment_target = '11.2'

But when I build the project, I still get the same ERROR! message. What am I missing?

Any help will be appreciated.


Do you have XCode 9.2 installed?

I have XCode 9.2 and RubyMotion 5.7 installed.

Try removing all references to app.deployment_target (it’ll default to latest). You can also run rake config to see what values are being set for the project.

Aside: My general recommendation is to try building a SpriteKit game first. This is a sample repository I’m working on. Mind cloning it telling me what you think?

I added the app.deployment_target line in. When it wasn’t there, I was getting the ERROR! message which is why I added in the app.deployment_target line in. I’d quite like to understand what’s missing if you have any other ideas? :slight_smile: rake config didn’t return anything.

Thanks for the tip - I’ll give SpriteKit a look but to be honest, I don’t think I’m in a position to comment on other people’s repos just yet as I’m still developing my understanding. This is the first app I’m attempting to build :slight_smile:

RubyMotionSpriteKit is all vanilla SpriteKit (no dependencies). There were some common patterns that emerged from my own games, so I put some of that wisdom together in a neat package.

I haven’t seen much work being done on motion-game recently. But there is a game dev Slack channel on Motioneers if you want to say hello there:

OK - thanks. I’ll join the channel and take it from there.

I’m in Slack all the time too. So feel free to DM me with any questions.